Jump to content

Vetus M4. Fuel Stop Solenoid Not Working

Recommended Posts

Hi All,


I can't get this out my head...and am sure someone knows


So we started the engine up today but the fuel stop solenoid wouldn't trigger when the panel was switched off.


Here's what we have done to diagnose so far:


Cabling is brand new as is the panel (and key barrel - Brand new in the last couple of weeks). (When the key on the panel is turned to the off position, 12v is getting to the solenoid but the solenoid doesn't trigger).


The solenoid isn't seized because it has a manual bypass which moves freely (and this stops fuel)


This solenoid has two cables coming out (but the wiring diagram shows only one white cable going down to it).. we have tried this to both cables (one at a time) and still nothing.


The engine has been unused since new and has been sitting for sometime.


We suspect the solenoid has died but at £100 (and I can't one in motor factor) we don't want to replace if we have missed something obvious.. any ideas??


Thanks all in advance,


Link to comment
Share on other sites

does it need 12v to make or break the solenoid? do you need to power it to shut off the fuel or so you need to stop powering it to shut of the fuel? if the wiring is correct then you be wanting a new one, you can try hitting it with a hammer, does not often fix the problem but it makes you feel better!


As my old boss used to say, "if I can't fix it, I will f*ck it up so no-one can!" 

Link to comment
Share on other sites

Thanks Alan, I need to print a copy of that off :)


Mark, its power to make, we tried runing a cable direct from the battery and just touching the cable (either, both).. then whack with a hammer lol (feel a bit better although I dont want to miss and damage my new paint job on it!).. 


I think its dead.. shame its going to make a mess removing it though so we will leave for a later date.. thankfully we can still test fire it up and stop on the manual one.. 


But still that seems all that's broken so its not bad for what we paid ;)

Link to comment
Share on other sites

Just an update incase anyone is reading this from the search engines.


Problem resolved: We didn't supply a negative.. only a postive ...You need to supply a negative to one of the cables (either) and it works.. funny that!  :trophy

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Sponsors

    Norfolk Broads Network is run by volunteers - You can help us run it by making a donation

  • Create New...

Important Information

For details of our Guidelines, please take a look at the Terms of Use here.