Jump to content
  • Announcements

    Welcome! New around here? Take a look at the New Members' Guide for some pointers.

    Not a member yet? Sign up here and you can soon be chatting away with friends old and new..

    Check out our Handy Information section if you're after something quickly!

Raymarine Radar problem


Recommended Posts

Hi all,

Jupes here (adam).

We have on board a Raymarine C series (C120) display with st60 speed and depth together with GPS linked to both the C120 oand the VHF radio.

There is also a 2kw Raydome, however, since we acquired the boat, the radar has never worked. So now its time to fix it!!!!

I have only a little knowledge of these set ups, but what I have ascertainined is the following....

a) When we power up the C120 unit, the radar page displays the error mesaage No SCanner - No data (though I have been unable to locate this error message in any of the manuals).

B) in the top right of the c120 display, you can see the components connected and their status (ie the GPS icon shows "fix" indicating that it is working. The Radar icon displays nothing, indication (obviously) it is inactive/not connected.

c) Using the C120 diagnostics tools, one screen shows active connections to GPS, Depth and Speed devices, but there is no Raydome device displayed.

d) in the software diagnostice screen on the C120. Apparently the Radar system is running version 0.0, possibly suggesting that it requires a software download to operate???

I have checked the C120 back panel to ensure the connection cable is secure and it seems OK and beyond that I am not sure where to go as it will involve removing the dome for example. or whether its simply my thoughts on the software version.

Any clues???

adam

Link to comment
Share on other sites

Hi guys, though the scanner is 2kw you do not say if it is the later type purchased with the C120, in which case there will not be need for any upgrade, though the latest software does have other advantages. If it is a Pathinder scanner it may well need a software "patch" (stand alone not the biggie) Can you give a better description of the scanner?

We will soom be coming to collect te Walker Bay soon so if it's not sorted I will have a peek then if you want if you're around.

Link to comment
Share on other sites

Thank you Antares.

I am not sure about the Raydome, other than that it was definately installed with the C120 at the time of original purchase (2002 by previous owner) as I have a copy of the installation invoice.

Clearly it has never worked. The previous owner didnt even register the product for warranty. I have actually just managed to register it online (clearly if it had already been, it would not have accepted the serial number).

This has enabled me to download the lastest version of the c120 software. I am going to put this version on (cant do any harm I guess) and it will either fix it or not!!!

Would be great to meet up with you at Goodchilds....just let us know when and if its still not fixed, any help would be welcomed.

adam

Link to comment
Share on other sites

A little more information that may help you.

If you have a 2KD RD218 scanner then it is compatible.

If you have a Pathfinder scanner below serial # 122000 it is completely incompatible.

A Pathfinder between serial # 1220001 and 0530157 will require an upgrade.

A Pathfinder above serial 0530158 is compatible.

BTW there should be a greyed out scanner in the top right hand corner if it is connected and recognised even if it's not working.

Link to comment
Share on other sites

Hi again,

I have just dug out the original invoice.

Oopsy its a C80 not a C120 s/n 0740845 product code E02020

The Raydome is simply described as 2Kw x18" serial nr 0840412 product code M92650-s. All fitted in Sept 2004.

The scanner Icon on the top right hand corner is not greyed out, suggesting that it is not connected??

rgds

adam...

Link to comment
Share on other sites

Hi ya,

I dont think it has a cross through it David, though I will check tommorrow when I look again. Its no big issue, and it would just be nice to have everything working before we next go seaward.

rgds

adam...

Link to comment
Share on other sites

From the posts above, I think it's reasonably safe to say that the other instruments and display are working more or less as designed. Before getting into a long and potentially complicated series of diagnostics, is it possible to examine the inside of the radome with a Mk. 1 Eyeball? That would allow you to exclude one of the most common problems with marine radar (particularly if it's not been used) - corrosion of metal parts inside the radome, so that whilst the electronic components may still function, the mechanical components are locked solid.

Link to comment
Share on other sites

Agreed Teademon, but that was covered early on in the initial thread about this problem and I assume (hope) it has already been checked.

It’s all Adam’s fault , he started a new thread on it, :grin::naughty: I might see if I can merge the posts to give a clearer progression.

Link to comment
Share on other sites

Hi guys

oopsy....my wife always says its my fault too!!!

No, I havent checked inside the dome, I cant find a small enough screwdriver to get to the screws to open up the top cover, and it seems the only option to get into the dome is to remove it from the arch...which was what I was trying to avoid...doh!

Having installed the latest version of the software...as expected...no change, however, the update gives me a slightly different top right set of icons on the screen which shows the status of attached components.

GPS shows "fix" so its working, I now have an AIS Icon and this is crossed out (as I do not have AIS functionality) The radar icon is white...but does not have a cross on it, and there is a boat icon (dunno what thats for) and that is also white but with no cross on it. There is also an icon called "pilot" and that has a cross on it.

I do recall speaking to a chap some time ago who suggested that he'd had a similar problem and that it was the drive belt that rotates the moving part of the scanner that needed replacing.

Is the general concensus that I should remove the dome and do a physical inspection?

Thank you all for your help on this...

kind regards

adam...(stupider missed)

Link to comment
Share on other sites

Adam, I seem to recall saying before, there is no need to remove the dome from the arch, there are 7 screws on the top of the raydome, assuming it is contemporary with the C80, undo these and the "lid" comes off, they are just standard pozi drive. The new icons are:

Boat is the fishfinder module

Pilot is if you have an autopilot fitted as they can be controlled from the C series display.

The fact that the Radar icon is there shows that the C80 "sees" the radome, when the radar is working then the scanner on the icon will rotate.

Link to comment
Share on other sites

I do recall speaking to a chap some time ago who suggested that he'd had a similar problem and that it was the drive belt that rotates the moving part of the scanner that needed replacing.

The fact that the Radar icon is there shows that the C80 "sees" the radome, when the radar is working then the scanner on the icon will rotate

the motor could have burnt out?

Jonny ice sliceice sliceice sliceice slice .

Link to comment
Share on other sites

Hi ya...

The raydome screws on this unit are located on the underside, rather inconveniently, as there is less than a 2" gap between this and the arch (would need an L shaped screwdriver to get to it.) Unbolting the whole units seems fairly simply, but would mean i could be in a precarious position holding the unit up whilst trying to undo the 4 screws.

Good question about how I turn it on...I dont...I am assuming that with all the switches on the main switch/fuseboard controlling power to Nav, Echo, VHF etc set to on, then power is getting to it, and then assuming that when I turn on the c80 it all then would work..(but clearly not).

Think along similar lines, if whoever wired it in didnt wire the power to the obvious switchpoint, there is a very slim possibility its been wired to the aux switch (which I will try tommorow). Its rare that I switch this one as all it controls is the cigarette lighter point, a small map reading light, and as I most recently found out to my delight, an Ipod dock and transmitter on the instrument panel which I originally thought was a mobile phone dock. Maybe, just maybe the power is on this circuit.

I will check tommorrow when I am at the Marina.

Thankyou all for all your help on this, and I am sure its probably something stoopid like this that is the problem, given all the process of elimination help you have given.

kind regards

Jupes

Link to comment
Share on other sites

You appear to have the earlier pathfinder raydome Adam, the later ones usually sold with the C series have the screws on top.

From your last post it appears that it is possibly not working because you have not turned it on.

The radar must be activated via the soft switches on the control panel, first to standby and then to transmit. When in normal operating mode briefly press the power switch but not long enough for the 3 second switch off countdown. This will give you a menu along the bottom above the buttons (soft switch) which will allow you to power up the Mag, after it has warmed up the switches will allow you to either leave it on standby or transmit. The actual power for the radar scanner is taken direct from the C series unit so there will be no extra power cables, the exception is for the larger open array scanners that need more power for the rotation motor.

Link to comment
Share on other sites

Hi ya,

that sounds really positive :) Will give that a go...spose I should have read all the manuals, but the previous owner very kindly left me with a whole sackfull and I assumed this stuff would work when you press the "on" button. All makes sense and will give it a go tommorrow.

If you are right, and I am sure you are...thats a very large beer I owe you :) redeemable anytime! :bow

adam...

Link to comment
Share on other sites

:(

Hi ya...

well.....I briefly pressed the power switch and, as you rightly said, a menu above the soft keys appears (least I know how I should turn on the unit). However....the radar tx/standby and the scanner options are not hilighted, whereas the final option of palette (day/night lighting) is higlighted and can be selected using the soft key. In other words, I am unable to enter a selection under tx/standby.

Talking to another chap today, and looking at the diagnostics screen again, the raydome is listed as having "0kW" power. His suggestion was that power was not getting up to the dome perhaps because there is a blown fuse. Do you happen to know if there is an in-line fuse somewhere either in the cabling or in the dome itself?

kind regards

adam...

Link to comment
Share on other sites

Bugger! That's really about as far as I can go remotely Adam, I'm all out of options as there is no fuse other than the internal one in the C series. Could be a broken cable I guess but without being on site with a Mega it's just stabbing in the dark really. In the next couple of weeks or so we will be up to pick up the Walker Bay so I could have a quick squiz then if you are around. This may well be a job for the Raymarine man. :?

Link to comment
Share on other sites

Adam, another thought occurs, was the unit on a “radar†display page when you pressed the power button. The soft switches are page sensitive so if it was not then the radar on / off soft switches will not appear. I hesitated to mention it before as I thought, of course you did, perhaps a mistake. The sequence is: press the "page" button, select the radar display page from the icons that will appear above the buttons, then press the power switch briefly and the soft switches should appear. If you want me to talk you through it when you are on board you have my cellphone number.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • NBN Mobile App

  • Our Sponsors

    Norfolk Broads Network is run by volunteers - You can help us run it by making a donation

×
×
  • Create New...

Important Information

For details of our Guidelines, please take a look at the Terms of Use here.