Jump to content
  • Announcements

    Welcome! New around here? Take a look at the New Members' Guide for some pointers.

    You can Sign up or log in with your Facebook account and you can soon be chatting away with friends old and new..

    Check out our Handy Information section if you're after something quickly!

  • If you would like to support the forum, please consider visiting the forum shop, where you can purchase such items as NBN Burgees, Window Stickers, or even a custom Limited Edition Wooden Throttle Control Knob

    Forum Shop

Sazzajn

Bilge Pump Overrunning All Of A Sudden....why?

Recommended Posts

Hi fellow boaters.....looking for some advice....our bilge pump has all of a sudden started to overrun slightly ie once the water has finished being pumped out, rather than stopping (as it used to do), it now carry’s on for a little longer....why / what would cause this to happen??

Thanks in advance for any insightful help.

 

 

Sent from my iPhone using Norfolk Broads Network

Share this post


Link to post
Share on other sites

My guess would be float switch sticking slightly. 

Share this post


Link to post
Share on other sites

Slightly sticking or maybe wear in the pivot. Another possibility is something catching the float as it returns or maybe debris in the way. If its one of those awful built in automatic items then you may not be able to get to the float to clean / service it.

  • Like 1

Share this post


Link to post
Share on other sites

oil in the bilge water is a possible cause. Try cleaning the pump and also clean the bilges out.

Share this post


Link to post
Share on other sites

Our bilge pumps are fitted in stainless trays, it is just a case of removing the jubilee clip and pulling apart the bullet connections and the unit can be lifted out for inspection/repair. 

On our last allocation I had to replace one of the bullet connections because it was corroded.

My guess it like the other comets is that you may need a new float switch.

Regards

Alan

Share this post


Link to post
Share on other sites

Thank you all for the help and advice...much appreciated as always!


Sent from my iPhone using Norfolk Broads Network

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • NBN Mobile App

    Our new mobile app is available now on Android and iOS!

    Get it on Google Play

×

Important Information

For details of our Guidelines, please take a look at the Terms of Use here.